Category Archives: Cloudlinux

Cloudlinux Yum Update Error

Working on a server today I got a cloudlinux yum update error


yum upgrade
Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
* cloudlinux-x86_64-server-6: cl.banahosting.com
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-379.14.1.lve1.1.9.9.el6 will be installed
--> Processing Dependency: kmod-iolimits-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
--> Processing Dependency: kmod-lve-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
---> Package kernel-firmware.noarch 0:2.6.32-379.11.1.lve1.1.9.8.2.el6 will be obsoleted
---> Package kernel-firmware.noarch 0:2.6.32-379.14.1.lve1.1.9.9.el6 will be obsoleting
---> Package kernel-headers.x86_64 0:2.6.32-379.11.1.lve1.1.9.8.2.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-379.14.1.lve1.1.9.9.el6 will be an update
---> Package liblve.x86_64 0:1.1-0.40.el6.cloudlinux will be updated
---> Package liblve.x86_64 0:1.2-0.1.el6.cloudlinux will be an update
---> Package liblve-devel.x86_64 0:1.1-0.40.el6.cloudlinux will be updated
---> Package liblve-devel.x86_64 0:1.2-0.1.el6.cloudlinux will be an update
---> Package libtiff.x86_64 0:3.9.4-6.el6_3 will be updated
---> Package libtiff.x86_64 0:3.9.4-9.el6_3 will be an update
---> Package libtiff-devel.x86_64 0:3.9.4-6.el6_3 will be updated
---> Package libtiff-devel.x86_64 0:3.9.4-9.el6_3 will be an update
---> Package lve.x86_64 0:1.1-0.40.el6.cloudlinux will be updated
---> Package lve.x86_64 0:1.2-0.1.el6.cloudlinux will be an update
--> Processing Dependency: kmod-lve >= 1.2 for package: lve-1.2-0.1.el6.cloudlinux.x86_64
---> Package selinux-policy.noarch 0:3.7.19-155.el6_3.8 will be updated
---> Package selinux-policy.noarch 0:3.7.19-155.el6_3.13 will be an update
---> Package selinux-policy-targeted.noarch 0:3.7.19-155.el6_3.8 will be updated
---> Package selinux-policy-targeted.noarch 0:3.7.19-155.el6_3.13 will be an update
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-320.17.1.lve1.1.7.3.el6 will be erased
--> Processing Dependency: kernel-uname-r = 2.6.32-320.17.1.lve1.1.7.3.el6.x86_64 for package: kmod-lve-2.6.32-320.17.1.lve1.1.7.3.el6.x86_64-1.1-9.2.4.el6.x86_64
---> Package kernel.x86_64 0:2.6.32-379.14.1.lve1.1.9.9.el6 will be installed
--> Processing Dependency: kmod-iolimits-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
--> Processing Dependency: kmod-lve-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
---> Package lve.x86_64 0:1.2-0.1.el6.cloudlinux will be an update
--> Processing Dependency: kmod-lve >= 1.2 for package: lve-1.2-0.1.el6.cloudlinux.x86_64
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-379.14.1.lve1.1.9.9.el6 will be installed
--> Processing Dependency: kmod-iolimits-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
--> Processing Dependency: kmod-lve-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 for package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
---> Package kmod-lve-2.6.32-320.17.1.lve1.1.7.3.el6.x86_64.x86_64 0:1.1-9.2.4.el6 will be erased
---> Package lve.x86_64 0:1.2-0.1.el6.cloudlinux will be an update
--> Processing Dependency: kmod-lve >= 1.2 for package: lve-1.2-0.1.el6.cloudlinux.x86_64
--> Finished Dependency Resolution
Error: Package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 (cloudlinux-x86_64-server-6)
Requires: kmod-lve-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
Error: Package: lve-1.2-0.1.el6.cloudlinux.x86_64 (cloudlinux-x86_64-server-6)
Requires: kmod-lve >= 1.2
Installed: kmod-lve-1.1-9.20.el6.x86_64 (@cloudlinux-x86_64-server-6)
kmod-lve = 1.1-9.20.el6
Error: Package: kernel-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64 (cloudlinux-x86_64-server-6)
Requires: kmod-iolimits-2.6.32-379.14.1.lve1.1.9.9.el6.x86_64
You could try using --skip-broken to work around the problem

The fix was editing /etc/yum.conf and remove from exclude line kmod-*